AccueilPortailFAQRechercherS'enregistrerConnexion

Partagez | 
 

 [Résolu] affichage php

Voir le sujet précédent Voir le sujet suivant Aller en bas 
AuteurMessage
Petit Denis
Administrateur


Masculin
Nombre de messages : 5866
Localisation : Quétigny

Date d'inscription : 02/07/2006

MessageSujet: [Résolu] affichage php Sam 30 Avr 2016, 12:19

Salut,
"php, c'est bon ! mangez-en !" dit scraper.
Alors pour pas mourir idiot, je m'y mets (doucement).
Installé : winampserver64 sur win8.1
Services démarré.
Une page php créée dans le sous-dossier www comme indiqué.
Éditeur texte Editplus3 avec coloration syntaxique...
Tout va bien.
Je commence par un truc simple et là je bloque.

Code:
<p><?php include("menu.php"); ?><br />
pourquoi ça marche pô ?<br />
<?php echo '<p>ça marche !</p>';?></p>

Un appel php pour écrire le contenu du menu.php (pas d'affichage).
Pourquoi ça marche pô ? (html correctement affiché)
Un appel php avec la fonction echo qui affiche ça marche !';?>
Le truc en rouge devrait pas apparaître.

menu.php est dans le même sous-dossier que la page qui l'appelle. (codage UTF8 sans BOM, bien sûr).
Vu que je bloque sur ce truc aussi simple, ça promet pour les futures pages !!!

Si quelqu'un voit où je me plante... ben 1001 mercis !

_________________
Petit Denis
Vous pouvez soutenir PCLand, par un don.



Dernière édition par Petit Denis le Lun 02 Mai 2016, 21:10, édité 1 fois
Revenir en haut Aller en bas
Voir le profil de l'utilisateur
migau
Administrateur


Masculin
Nombre de messages : 11443
Localisation : maine et loire

Date d'inscription : 14/08/2006

MessageSujet: Re: [Résolu] affichage php Sam 30 Avr 2016, 12:29

hello

voilà ma page d'accueil

Code:


<?php
    include("haut.php") ;
 ?>


<?php include("design.html") ; ?>


<?php include("onglet.php") ; ?>

il y a longtemps que je n'ai pas fait de php, j'ai tout oublié

_________________
Best regards



__________________________
Pc Land a besoin de votre aide.

_________________________
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://michegau.free.fr/index.php
Petit Denis
Administrateur


Masculin
Nombre de messages : 5866
Localisation : Quétigny

Date d'inscription : 02/07/2006

MessageSujet: Re: [Résolu] affichage php Sam 30 Avr 2016, 22:14

Bon fait je m'y suis mal pris.
Après un peu de lecture, j'ai donc wampserveur 32 bits installé (la version 64 est déconseillée).
L'icône est verte dans le systray (preuve que les services fonctionnent).
Quand je lance localhost, j'arrive à la page


Et quand je clique sur le dossier test (on ne le voit pas sur la capture précédente mais il est là).
J'obtiens...



Je ne trouve rien sur le net. J'ai regardé vers quelques forums, mais rien trouvé.
Dans le dossier test, il y a un index.php et un menu.php appelé par l'index. Mais vu que même l'index ne s'ouvre pas...

Mon erreur d'avant : je passais par l'explorateur de fichier et clic droit sur ouvrir avec... le fichier s'affiche mais sans l'include...

Mon souci est donc bien au niveau du fonctionnement de wampserver...


_________________
Petit Denis
Vous pouvez soutenir PCLand, par un don.

Revenir en haut Aller en bas
Voir le profil de l'utilisateur
migau
Administrateur


Masculin
Nombre de messages : 11443
Localisation : maine et loire

Date d'inscription : 14/08/2006

MessageSujet: Re: [Résolu] affichage php Sam 30 Avr 2016, 22:59

hello

mon site se trouve dans le répertoire Web( le nom que j'ai donné, mais dans le sous dossier www de wampserver


_________________
Best regards



__________________________
Pc Land a besoin de votre aide.

_________________________
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://michegau.free.fr/index.php
Petit Denis
Administrateur


Masculin
Nombre de messages : 5866
Localisation : Quétigny

Date d'inscription : 02/07/2006

MessageSujet: Re: [Résolu] affichage php Sam 30 Avr 2016, 23:31

Je progresse... en fait la configuration de wampserver n'est pas adaptée à windows 8 (qui utilise par défaut les ipv6).
Maintenant j'ai une erreur 403 forbidden sur le port 80.
Je vais trouvé !

_________________
Petit Denis
Vous pouvez soutenir PCLand, par un don.

Revenir en haut Aller en bas
Voir le profil de l'utilisateur
migau
Administrateur


Masculin
Nombre de messages : 11443
Localisation : maine et loire

Date d'inscription : 14/08/2006

MessageSujet: Re: [Résolu] affichage php Dim 01 Mai 2016, 10:24

hello

dans la barre de navigation, il faut

http://localhost/ et ensuite tu tapes test pour avoir

http://localhost/test

wamp est une usine à gaz.
j'avais easyphp que j'ai désinstallé pour mettre wamp pour t'aider
et mon forum ne s'affiche plus, je sens que je vais revenir easy.php

la commande

msql_connect est dépréciée, il faut modifier par, msqli_connect ( le i en plus )


j'ai modifié le port 80 par 8080

http://localhost:8080/ parce que j'ai skype

dans le fichier php.ini modifié 3036 par 3037

ce qui me donne

http://localhost:8080/le-web/

je suis obligé de taper (le-web/ ) il ne reste pas en mémoire
mes (includes) ne fonctionnent plus



_________________
Best regards



__________________________
Pc Land a besoin de votre aide.

_________________________
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://michegau.free.fr/index.php
Petit Denis
Administrateur


Masculin
Nombre de messages : 5866
Localisation : Quétigny

Date d'inscription : 02/07/2006

MessageSujet: Re: [Résolu] affichage php Dim 01 Mai 2016, 11:19

Dès qu'on veut sortir des sentiers battus, il faut avoir des connaissances balèzes avant même de commencer. Dommage !
Je vais poser ma question chez ponx quand ça retombera en marche.
WAmp était également proposé pour la galerie piwigo, pareil, jamais réussi à faire fonctionner le truc...

php c'est bon, mangez-en mais pour le moment c'est indigeste !

_________________
Petit Denis
Vous pouvez soutenir PCLand, par un don.

Revenir en haut Aller en bas
Voir le profil de l'utilisateur
migau
Administrateur


Masculin
Nombre de messages : 11443
Localisation : maine et loire

Date d'inscription : 14/08/2006

MessageSujet: Re: [Résolu] affichage php Dim 01 Mai 2016, 11:42

hello

j'ai désinstallé wampserver et réinstallé sur C: et non pas sur une autre partition

sans rien toucher tout fonctionne

sauf la connexion à la BDD à cause de la commande msqli_connect

je verrai plus tard

par contre pour aller sur mon site en local, le suis obligé de taper /le-web , derrière localhost

je vais suivre ta conversation sur Ponx

_________________
Best regards



__________________________
Pc Land a besoin de votre aide.

_________________________
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://michegau.free.fr/index.php
Petit Denis
Administrateur


Masculin
Nombre de messages : 5866
Localisation : Quétigny

Date d'inscription : 02/07/2006

MessageSujet: Re: [Résolu] affichage php Dim 01 Mai 2016, 17:40

Si tu as vu sur ponx, ça y est cela fonctionne et les includes fonctionnent (du moins dans mon test).
Reste à reconstruire les autres pages.

En tout cas merci pour les idées ou les infos issues de tes tests.

_________________
Petit Denis
Vous pouvez soutenir PCLand, par un don.

Revenir en haut Aller en bas
Voir le profil de l'utilisateur
migau
Administrateur


Masculin
Nombre de messages : 11443
Localisation : maine et loire

Date d'inscription : 14/08/2006

MessageSujet: Re: [Résolu] affichage php Dim 01 Mai 2016, 19:07

ok, j'ai vu , otomatic te redirige vers le forum wampserver.

pour info, pour moi tout fonctionne également depuis que j'ai tout mis sur c:\

j'ai juste un message indiquant

pour se connecter à la BDD, la commande msql_connect is deprecied
à remplacer par msqli

bonne soirée



_________________
Best regards



__________________________
Pc Land a besoin de votre aide.

_________________________
Revenir en haut Aller en bas
Voir le profil de l'utilisateur http://michegau.free.fr/index.php
Petit Denis
Administrateur


Masculin
Nombre de messages : 5866
Localisation : Quétigny

Date d'inscription : 02/07/2006

MessageSujet: Re: [Résolu] affichage php Dim 01 Mai 2016, 20:23

effectivement sur c, ça fonctionne "mieux" !
C'est juste pas précisé ou alors vaguement : il est préférable...

_________________
Petit Denis
Vous pouvez soutenir PCLand, par un don.

Revenir en haut Aller en bas
Voir le profil de l'utilisateur
Petit Denis
Administrateur


Masculin
Nombre de messages : 5866
Localisation : Quétigny

Date d'inscription : 02/07/2006

MessageSujet: Re: [Résolu] affichage php Lun 02 Mai 2016, 21:10

Ça y est tout refonctionne parfaitement. En fait j'ai un .htaccess (en ligne) aussi présent en local, et c'est lui qui me bloque tout !

Je peux maintenant tester et m'amuser à découvrir le php...

_________________
Petit Denis
Vous pouvez soutenir PCLand, par un don.

Revenir en haut Aller en bas
Voir le profil de l'utilisateur
 

[Résolu] affichage php

Voir le sujet précédent Voir le sujet suivant Revenir en haut 
Page 1 sur 1

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
PC Land :: Le coin dépannage :: Dépannage Divers-